请选择 进入手机版 | 继续访问电脑版
开启辅助访问
 找回密码
 立即注册

手机号码,快捷登录

同花顺指标导入教程(附送指标源码)

风少爷2020-2-26| 8903 1|

46

主题

51

帖子

46

主题

资深老股民

Rank: 6Rank: 6

积分
1061
学习币
1005 个
现金
1151 元
首先需要说明的是同花顺手机版不能编写指标,所以请各位股票BB网(http://www.gupiaobb.com)的股友使用同花顺电脑版来导入指标。同花顺有个较大的优势是,一账户多登陆,并且自动同步。
源码导入

一、首先打开公式管理器或者快捷键ctrl+F打开


6d3d4dd532c3434a962a872c98c3d4fd.jpg

二、打开后选择技术指标,新建。然后在点击技术指标确定。

f0346f71ef1f4ab8ac4625775e764157.jpg


03a554828a434b74be1e90537af39f29.jpg


三、进入同花顺的公式编辑器后,可以看到有同花顺模式和通达信模式。适应不同习惯的股友。填写完名字、描述、参数和源码后,点确定。

fa692a28515749e886f909edc7aa2661.jpg

四、回到同花顺的股票主页面,在主图点击鼠标右键,选择常用线性和指标,就看到自己导入的股票指标了。如果没有就点击更多指标。(需要注意的是。有的指标主幅图都可以用的,通用)

9c345b8510d84d608d5c1063c90c400b.jpg

五、幅图指标的左下角有个指标,点击后出现了常用指标管理器。一般我们的指标都在自定指标里面,把我们的指标选中点击中间的箭头倒进右边。保存,就可以看见,指标出现在幅图的下面常用了。比较方面。

cc6369c24bab46f2b195dee8f7ab161d.jpg


文本和hxf模式导入

打开公式管理器或者快捷键ctrl+F打开

ae56eba634d247a5af3e27b96e849a59.jpg


右下角是导入文本和导入两个。导入文本就是导入一般的TXT格式。在这里需要注意的是。一定是同花顺导出的源码文本txt,不能自己新建,通达信的源码只能通过上面的第一步导入。导入就是同花顺特有的hxf模式。

117eb8e2c37c47fe8447f70b5e01588f.jpg


选股器导入
728cc5b3a54e448fac349be1bf18f4c3.jpg

选择条件选股跟上面的步骤一样,复制粘贴即可。

下面我分享个实用的股票指标和选股器源码给各位股友,股票指标源码如下:

EMA13:=EMA(C,13),colorwhite;
EMA21:=EMA(C,21),coloryellow;
EMA34:=EMA(C,34),COLORFF00FF;
EMA60:=MA(C,60),COLORFFCC66;
VAR2:=(2*CLOSE+HIGH+LOW)/4;
VAR3:=IF(YEAR>=2099 AND MONTH>2,0,1);
VAR4:=LLV(LOW,5);
VAR5:=HHV(HIGH,4);
散户:=EMA((VAR2-VAR4)/(VAR5-VAR4)*100,4)*VAR3;
庄家:=EMA(0.667*REF(散户,1)+0.333*散户,2)*VAR3;
DRAWTEXT(CROSS(散户,庄家) AND 散户<30,L-0.05,'←低吸'),COLOR00ffff;
DRAWTEXT(CROSS(庄家,散户) AND 散户>70,H+0.05,'←高抛'),colorgreen;
DRAWICON(CROSS(散户,庄家) AND 散户<30,L-0.05,'buy');
DRAWICON(CROSS(庄家,散户) AND 散户>70,H+0.05,'sell');
VAR9:=CLOSE-REF(CLOSE,5);
VARA:=EMA(EMA(VAR9,5),5)/EMA(EMA(ABS(VAR9),5),5);
VARC:=EMA(EMA(VAR9,20),20)/EMA(EMA(ABS(VAR9),20),20);

卖出:=IF(VARA>0 AND CROSS(VARC,VARA),90,100);
DRAWICON(卖出<0,H+0.05,'sell');
买线:=EMA(CLOSE,2);
卖线:=EMA(SLOPE(CLOSE,21)*20+CLOSE,42);
DRAWNULL:=DTSCSYL;
B1:IF(CROSS(买线,卖线),L-0.02,DRAWNULL),CROSSDOT,LINETHICK2,colormagenta;
S1:IF(CROSS(80,RSI)*30,H+0.02,DRAWNULL),CROSSDOT,LINETHICK2,coloryellow;
VC:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA (CLOSE,32))/MA(CLOSE,32)*100)/3;
S2:=IF(VC>20 AND FILTER(VC< REF(VC,1),5),H+0.02,DRAWNULL);
A0:=(L+H+C*2)/4;
A1:EMA(A0,14),colorblue,LINETHICK1;
A2:=EMA(A0,25),colorliblue,LINETHICK1;
A1X:=(A1-REF(A1,1))/REF(A1,1)*100;
A2X:=(A2-REF(A2,1))/REF(A2,1)*100;
看多:IF(A1X>=0 AND BARSLAST(CROSS(A1X,0))>0,REF((C+O)/2,BARSLAST(CROSS(A1X,0))),DRAWNULL),colormagenta;
逃顶:IF(A1X<0 AND BARSLAST(CROSS(0,A1X))>0,REF((C+O)/2,BARSLAST(CROSS(0,A1X))),DRAWNULL),colorcyan;
买入持股:IF(A1X>=0,A1,DRAWNULL),colorred,LINETHICK1;
卖出空仓:IF(A1X<0 AND A2X<0,A1,DRAWNULL),color009fff,LINETHICK1;
STICKLINE(CROSS(A1X,0),H,L,0,0 ),COLOR9933FF;
STICKLINE(CROSS(A1X,0),C,O,6,0 ),COLOR0000CC;
STICKLINE(CROSS(0,A1X),C,O,6,0 ),COLOR66cc33;
STICKLINE(CROSS(0,A1X),L,H,0,0 ),COLOR66CC33;

选股器源码:

VAR1:=EMA(EMA(CLOSE,9),9);
控盘:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;
STICKLINE(控盘<0,控盘,0,1,0),colorwhite;
A10:=CROSS(控盘,0);
无庄控盘:IF(控盘<0,控盘,0),colorwhite,NODRAW;
开始控盘:IF(A10,5,0),LINETHICK1,coloryellow;
STICKLINE(控盘>REF(控盘,1) AND 控盘>0,控盘,0,1,0),colorred;
有庄控盘:IF(控盘>REF(控盘,1) AND 控盘>0,控盘,0),colorred,NODRAW;
VAR2:=100*WINNER(CLOSE*0.95);
STICKLINE(VAR2>50 AND COST(85)0,控盘,0,1,0),COLORFF00FF;
高度控盘:IF(VAR2>50 AND COST(85)0,控盘,0),COLORFF00FF,NODRAW;
STICKLINE(控盘0,控盘,0,1,0),COLOR00FF00;
主力出货:IF(控盘0,控盘,0),COLOR00FF00,NODRAW;
ZHF:=(HHV(C,3)-LLV(C,3))*100/LLV(C,3)<=10;
LXKP:=高度控盘>REF(高度控盘,1) AND REF(高度控盘,1)>REF(高度控盘,2) AND REF(高度控盘,3)=0;
高控盘:IF(ZHF AND LXKP,10,0),colorwhite;

喜欢的朋友请点个赞支持一下哦。


0

主题

6

帖子

0

主题

老股民

Rank: 4

积分
927
学习币
921 个
现金
0 元
林璐璐|2020-11-4 16:26:02 | 显示全部楼层
快速回复
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

在线客服
QQ 851049438
发布 快速回复 返回顶部 返回列表